Archive Pages Design$type=blogging

Basic Command (Cisco Router) - Komputekid

Hostname Configuration Untuk memudahkan manajemen router dalam jumlah yang banyak, maka setiap router harus diberikan hostname sebagai penge...

cisco-logoHostname Configuration

Untuk memudahkan manajemen router dalam jumlah yang banyak, maka setiap router harus diberikan hostname sebagai pengenal. Pengenal ini berguna pada saat akan melakukan konfigurasi maupun monitoring dalam jaringan.
Untuk melakukan konfigurasi hostname, harus dilakukan pada global EXEC Mode, seperti berikut.

Router>enable
Router#conf
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname IlmuJaringan-ROUTER
IlmuJaringan-ROUTER(config)#exit
IlmuJaringan-ROUTER#
%SYS-5-CONFIG_I: Configured from console by console
IlmuJaringan-ROUTER#
IlmuJaringan-ROUTER#

Router Password

Password pada Router Cisco dapat diterapkan pada berbagai level maupun akses konfigurasi. Pada saat akan memasuki privileged EXEC mode dapat diimplementasikan password dengan menggunakan perintah sebagai berikut.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#enable password 123456

Jika ingin menerapkan password yang sudah dienkripsi pada saat akan memasuki privileged EXEC Mode, maka perintah  yang dapat digunakan adalah sebagai berikut.
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#enable secret 567890
Router(config)#^Z
Jika enable password dan enable secret digunakan bersamaan, maka yang akan digunakan oleh router adalah password yang dikonfigurasikan oleh enable secret.
Port Console yang sering digunakan untuk konfigurasi router juga dapat diberikan password dengan menggunakan perintah sebagai berikut.
Router#
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#line console 0
Router(config-line)#password cisco
Router(config-line)#login
Router(config-line)#exit
Sedangkan untuk akses konfigurasi yang menggunakan telnet dapat diberikan password, dengan menggunakan perintah berikut ini.
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#line vty 0 4
Router(config-line)#password cisco
Router(config-line)#login
Router(config-line)#exit
Secara default konfigurasi password pada line console maupun telnet tidak dienkripsi sehingga dapat dengan mudah dibaca, seperti terlihat berikut ini.
Router#show running-config
Building configuration…
 
Current configuration : 518 bytes
!
version 12.2
no service timestamps log datetime msec
!
line con 0
 password cisco
 login
line vty 0 4
 password cisco
 login
!
!
end

Untuk membuat password terenkripsi dapat digunakan perintah berikut ini.
 Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#service password-encryption


Banner

Mengkonfigurasikan banner sangat penting untuk pertimbangan keamanan suatu router, banner tersebut akan diperlihatkan pada saat ada user yang akan mengakses router. Peirntah yang dapat digunakan adalah sebagai berikut.
 Router(config)#banner motd #
Enter TEXT message.  End with the character ‘#’.
*********************************************
WARNING !!! Forbiden Access to this Device
*********************************************
#

Interface Configuration

Untuk mengkonfigurasikan interface Router Cisco, ada baiknya melihat terlebih dahulu interface apa saja yang dimiliki router tersebut. Perintah yang dapat digunakan adalah sebagai berikut
Router#show interface
FastEthernet0/0 is administratively down, line protocol is down (disabled)
  Hardware is Lance, address is 0060.3e14.7701 (bia 0060.3e14.7701)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00,
  Last input 00:00:08, output 00:00:05, output hang never
  Last clearing of “show interface” counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet0/1 is administratively down, line protocol is down (disabled)
  Hardware is Lance, address is 0060.3e14.7702 (bia 0060.3e14.7702)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00,
  Last input 00:00:08, output 00:00:05, output hang never
  Last clearing of “show interface” counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Sebagai contoh untuk mengkonfigurasikan IP Address pada interface router, dapat digunakan skenario jaringan berikut ini.
basic_cisco_1

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface f0/0
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
 
Router(config)#
Router(config)#interface f0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit



Saving Configuration

Cisco Router menggunakan dua konfigurasi yang disimpan pada dua file yang berbeda pula. Startup Configuration File adalah adalah file yang menyimpan konfigurasi yang akan digunakan router pada saat router tersebut pertama kali dihidupkan. Startup Configuration disimpan pada NVRAM sehingga tidak akan hilang pada saat router dimatikan maupun kehilangan power. Pada saat Router dihidupkan, Startup Configuration File akan di-copy ke dalam RAM untuk menjadi Running Configuration File. Karena disimpan dalam RAM, maka Running Configuration File akan hilang pada saat router kehilangan power.
Pada saat melakukan konfigurasi router, semua perintah konfigurasi akan disimpan pada Running Configuration File. Sehingga untuk mencegah kehilangan konfigurasi, maka konfigurasi yang tersimpan pada Running Configuration File perlu di-copy ke Startup Configuration File. Perintah yang dapat digunakan adalah sebagai berikut.

Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]
Router#
 Atau dapat juga menggunakan perintah singkat seperti berikut ini.
 Router#write
Building configuration…
[OK]
 
 
 
 
 

Basic Routing Table

Tabel routing adalah tabel yang akan digunakan router sebagai pedoman untuk mengirimkan paket data. Router hanya akan mengirimkan paket ke suatu network, jika network tersebut terdaftar didalam tabel routingnya. Jika ada sebuah paket yang menuju suatu network yang tidak terdaftar di dalam tabel routingnya, maka paket tersebut akan di-drop.
Yang akan ada di dalam tabel routing adalah network address dari jaringan yang dapat dituju beserta bagaimana cara router tersebut mencapai jaringan tersebut. Entry pada tabel routing tersebut bisa berupa network yang terhubung langsung (directly connected network) maupun network yang dapat dituju melalui router lain (remote network).
Sebagai contoh entry tabel routing untuk jaringan sederhana, dapat dilihat pada gambar dan uraian berikut ini.
 basic_cisco_1
Router#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
       i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
       * – candidate default, U – per-user static route, o – ODR
       P – periodic downloaded static route
 
Gateway of last resort is not set
 
C    192.168.0.0/24 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/1

COMMENTS

Name

Android Blogging Cisco Cloud Computing Download Ebook elektronik Error Code Flashdisk Games hack Hardware Info Info Teknologi Internet Jaringan Jaringan Komputer Jual Komputekid Komputer Linux Microsoft Office MikroTik Panduan Blog Pemograman Perbaikan Perbaikan Komputer Printer Recommended Product SEO TechNews Teknologi Tips Trik Tutorial Useful Software Windows 7 Windows 8 Windows XP
false
ltr
item
CatatanTKJ: Basic Command (Cisco Router) - Komputekid
Basic Command (Cisco Router) - Komputekid
http://www.ilmujaringan.com/wp-content/uploads/2013/03/cisco-logo-150x150.jpg
CatatanTKJ
http://phentemnote.blogspot.com/2014/05/basic-command-cisco-router-komputekid.html
http://phentemnote.blogspot.com/
http://phentemnote.blogspot.com/
http://phentemnote.blogspot.com/2014/05/basic-command-cisco-router-komputekid.html
true
2552346874649323927
UTF-8
Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago